Доколе приложение TheQ будет "вылетать" при использовании на iPhone 4? ;) началось после первого обновления и теперь могу читать только общую ленту(((((

Ответить
Ответить
Комментировать
0
Подписаться
0
1 ответ
Поделиться

Будучи разработчиком мобильных приложений могу прокомментировать, что для выявления ошибки было бы целесообразно с вашей стороны описать сценарий ваших действий, которые приводят к падению приложения. Чтоб это можно было воспроизвести. Так проще отлаживать и понимать в каком месте, что именно не работает.

Между тем стоит отметить, что со временем поддерживать работоспособность приложения на старых моделях смартфона становится все сложнее. Это обусловлено прежде всего политикой компании Apple. Предоставляемый SDK, который предлагается при появлении новых версий ios не содержит средств для поддержки старых версий. Мы просто видим предупреждения, что такая-то строка кода теперь не работает. И меняя значение на новое, в телефоне со старой версией ios данный участок кода перестает работать корректно.

При таких обстоятельствах приходится усложнять логику, учитывать разные версии системы и для каждого случая прописывать свое решение. Это существенно усложняет процесс и снижает темп разработки, что плохо отражается на конечном результате. Поэтому чаще всего принимается решение не поддерживать устаревшие версии (как это в общем-то делается и в Apple) и к сожалению вам как владельцу iPhone 4 в будущем новые версии приложений постепенно перестанут быть доступными.

3
0
Прокомментировать
Ответить
Читайте также на Яндекс.Кью
Читайте также на Яндекс.Кью